IPB

Здравствуйте, гость ( Вход | Регистрация )

 
Ответить в данную темуНачать новую тему
> обновление Php
Freekiller
сообщение 15.4.2013, 14:42
Сообщение #1


Активный участник
***

Группа: Пользователи
Сообщений: 37
Регистрация: 18.10.2010
Пользователь №: 1342



что то не получается обновить php. не подскажите что да как нужно сделать? стоит 5,2 хотелось бы обновиться до 5.4 или хотябы 5,3
Перейти в начало страницы
 
+Цитировать сообщение
Admin
сообщение 22.5.2013, 16:50
Сообщение #2


Администратор
***

Группа: Главные администраторы
Сообщений: 838
Регистрация: 7.3.2008
Из: Орск
Пользователь №: 1



а что не получается?


--------------------
Лучший игровой сервер - Земля: карта всего одна, но на 6 миллиардов игроков;
читеров нет, админ терпеливый, но если уж забанит...


Перейти в начало страницы
 
+Цитировать сообщение
Predator
сообщение 24.5.2013, 19:20
Сообщение #3


Активный участник
***

Группа: Пользователи
Сообщений: 34
Регистрация: 15.2.2012
Из: Чебоксары
Пользователь №: 1594



Цитата(Freekiller @ 15.4.2013, 15:42) *
что то не получается обновить php. не подскажите что да как нужно сделать? стоит 5,2 хотелось бы обновиться до 5.4 или хотябы 5,3

есть же специальный пакет для обновления!


--------------------
Программирую для IPB
Перейти в начало страницы
 
+Цитировать сообщение
patrig
сообщение 27.5.2013, 16:20
Сообщение #4


Новичок
*

Группа: Пользователи
Сообщений: 5
Регистрация: 20.2.2010
Пользователь №: 1153



Цитата(Predator @ 24.5.2013, 19:20) *
есть же специальный пакет для обновления!

КЕП! huh.gif
Перейти в начало страницы
 
+Цитировать сообщение
Freekiller
сообщение 9.8.2013, 19:21
Сообщение #5


Активный участник
***

Группа: Пользователи
Сообщений: 37
Регистрация: 18.10.2010
Пользователь №: 1342



после обновления падает с ошибкой в файле php5ts.dll, логи пустые
php 5.4.4
Apache_2.2.22
подключенные модули

extension=php_bz2.dll
extension=php_memcache.dll
extension=php_curl.dll
extension=php_gd2.dll
extension=php_gmp.dll
extension=php_mbstring.dll
extension=php_mcrypt.dll
extension=php_mysql.dll
extension=php_mysqli.dll
extension=php_sockets.dll
extension=php_sqlite.dll
extension=php_xsl.dll
extension=php_pdo.dll
extension=php_xmlrpc.dll

Перейти в начало страницы
 
+Цитировать сообщение
Admin
сообщение 10.8.2013, 16:04
Сообщение #6


Администратор
***

Группа: Главные администраторы
Сообщений: 838
Регистрация: 7.3.2008
Из: Орск
Пользователь №: 1



Сделай поиск по диску с: файла php5ts.dll везде он должен быть одинаковый по всем путям.


--------------------
Лучший игровой сервер - Земля: карта всего одна, но на 6 миллиардов игроков;
читеров нет, админ терпеливый, но если уж забанит...


Перейти в начало страницы
 
+Цитировать сообщение
Freekiller
сообщение 10.8.2013, 16:31
Сообщение #7


Активный участник
***

Группа: Пользователи
Сообщений: 37
Регистрация: 18.10.2010
Пользователь №: 1342



так он же встречается только в папке php
на С его нет нигде
зы как обновить апача до 2.4 в стп?
Перейти в начало страницы
 
+Цитировать сообщение
Admin
сообщение 29.8.2013, 19:16
Сообщение #8


Администратор
***

Группа: Главные администраторы
Сообщений: 838
Регистрация: 7.3.2008
Из: Орск
Пользователь №: 1



1. Ну распакуйте MSI файл.
2. удалите старый апач кроме папки с конфигами и логами(если ненужны то можно удалить папку лог)
3. потом копируете то что распаковали в п. 1 в папку где был старый апач.
4. проверяете работу апача.

В принципе так можно обновить всё кроме mysql там нужно базы либо конвертировать либо делать бекап и пере залить с нуля.


--------------------
Лучший игровой сервер - Земля: карта всего одна, но на 6 миллиардов игроков;
читеров нет, админ терпеливый, но если уж забанит...


Перейти в начало страницы
 
+Цитировать сообщение

Ответить в данную темуНачать новую тему
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 



RSS Текстовая версия Сейчас: 16.9.2019, 23:42
Друзья:

Locations of visitors to this page